Web Conferencing :: System Requirements

Printer-friendly versionSend to friendPDF version

To get the most out of using Blackboard Collaborate, you'll need to ensure that your computer meets the minimum system requirements, that you have a compatible headset with built-in microphone, and that you have a good, preferably broadband, Internet connection. Please review the specifications below to ensure that youur equipment is capable of running Blackboard Collaborate; if you need additional assistance with configuring your system, contact the Technology Help Desk at (707) 826-HELP (4357).

Note that the Technology Help Desk will not be able to assist you with Linux or Solaris issues.

Audio Equipment

The primary options are:

  • a headset with attached noise-canceling microphone (recommended)
  • a microphone and computer speakers

Most microphones and headsets work fine so feel free to pick any you'd like. The following have been tested by students and found to work well:

  • Gigaware USB Stereo Headset with Microphone (43-122)
  • Plantronics Behind-the-Head Stereo Headset with Microphone
  • Headsets from Microsoft and Logitech with noise-canceling microphones

Headsets connect to computers using either by directly plugging into the microphone and headset ports or by connecting to any USB port on your computer; the latter is recommended for better sound quality and less "noise leakage".

Note for Mac users: According to the Blackboard Collaborate website, Mac users should use USB headsets to ensure compatibility. However, if your Mac has a built-in microphone and speakers, these integrated components are compatible with Blackboard Collaborate, so purchasing a headset is optional.

Computer Equipment

Windows:

  • Windows Vista (32 bit with 32 bit JVM )
  • Windows Vista (64 bit with 64 bit JVM)
  • Windows 7 (32 bit with 32 bit JVM)
  • Windows 7 (64 bit with 64 bit JVM) 
  • Pentium III 1 GHz processor
  • Sun Java 1.5.0_17 or Sun Java 1.6.0_12  and greater

Supported Browsers

  • Windows Vista - Internet Explorer 7, Internet Explorer 8 and Firefox 3.x
  • Windows 7 - Internet Explorer 7, Internet Explorer 8, Firefox 3.x and Google Chrome 5.0

Macintosh:

  • OS X 10.5 (32 bit with 32 bit JVM)
  • OS X 10.6 (64 bit with 32 bit JVM)
  • OS X 10.6 (64 bit with 64 bit JVM)
  • G4, G5 or Intel processor
  • Apple Java 1.5.0_16 (J2SE5 - 32 bit), Apple Java 1.6.0_07 (J2SE6 - 64 bit)

Supported Browsers:

  • OS X 10.5 - Safari 4 and Safari 5
  • OS X 10.6 - Safari 4 and Safari 5

Linux

  • openSUSE 11 (64 bit with 64 bit JVM)
  • Ubuntu 9.10 (64 bit with 64 bit JVM)
  • Pentium III 1 GHz processor
  • Sun Java 1.5.0_17 or Sun Java 1.6.0_12  and greater

Supported Browsers:

  • openSUSE 11 - Firefox 3.x
  • Ubuntu 8.10 - Firefox 3.x

UltraSPARC Solaris

  • Solaris 10 (SPARC only) (64 bit with 64 bit JVM)
  • UltraSPARC IIc 500 MHz processor
  • Sun Java 1.5.0_17 or Sun Java 1.6.0_12  and greater

Supported Browsers:

  • Solaris 10 (SPARC only) - Firefox 3.x

In addition, all systems require:

  • 256 MB of free RAM
  • 20 MB free disk space
  • Broadband Internet connection

Related Topics

Web Conferencing
feedback