Web Conferencing :: Software Information for ITCs

Printer-friendly versionSend to friendPDF version

Here are the results of ITS's in-house Elluminate testing. Refer to Elluminate's support page for late-breaking compatibility information.

Operating System and Browser Compatibility

  Mac OS X 10.6.x Windows 7 32-bit SP1 Windows 7 64-bit SP1
Safari 5.x X    
Internet Explorer 8   X X
Internet Explorer 9   X X
Firefox 3.6.x   X X
Firefox 4   X X
Chrome 10.x X* X* X*

*Java not detected, but works

Elluminate users will need to have these minimum system requirements

 

Elluminate and JAWS Screen Reader

The supported versions of JAWS Screen Reader, according to the Elluminate website, are JAWS 9, 10, and 11. Version 12 of JAWS is current and testing results were the same as version 11, so it is likely that Elluminate's website just needs to be updated. JAWS works in Elluminate with Windows 7 32-bit

You will be required to install:

When updating Java, you will also need to update the Java Accessibility Bridge.

Details for getting JAWS/Java Accessibility Bridge  to work with Windows 7 64-bit are forthcoming - currently, it is necessary to do a manual install.

Note: Java Accessibility Bridge is already pre-installed on Macintosh systems with the Macintosh version of Java. JAWS does not run on Macintosh. Mac users needing screen reading should turn on VoiceOver (use command-F5 or access through the System Preferences Universal Access Preference Pane).

You may need to refer to Elluminate’s knowledgebase of FAQs regarding Java

Useful links for Elluminate Accessibility Tools (including JAWS Screen Reader)

Related Topics

Web Conferencing
feedback