
7. Spreadsheet

Introduction
Spreadsheet is a table consisting of rows and columns. It is a number-crunching software that allows
you to calculate the numbers and make predictions or “what if” analyses. The intersection of rows
and columns makes cells in which you insert data. The data can be either numbers or letters. If it is a
number or a formula, spreadsheet calls it value; if it is letters, it is called label.

Each cell has an address, or location, indicated by its column and row headings. For example, the
cell in the upper left corner of a spreadsheet, at the intersection of column A and row 1, is A1. The
cell to the right of A1 is B1, the cell immediately beneath A1 is A2, and so on. Rows are numbered
from top to bottom, 1 through 65,635. Columns are identified with letters from A to Z, then AA to
ZZ, and on through IV, from left to right. Works  spreadsheets have a theoretical limit of 65,635
rows and 256 columns (16,777,216 cells), based on memory available.

Entering and Editing Worksheet Data
People use spreadsheets primarily to store data and perform calculations. This chapter discusses the
various types of data that you can enter into Excel.

Types of Worksheet Data
As you know, an Excel workbook can hold any number of worksheets, and each worksheet is made
up of cells. A cell can hold any of three types of data:

A value
Text
A formula

The worksheet also can hold charts, maps, drawings, pictures, buttons, and other objects. These
objects actually reside on worksheet’s draw layer, which is an invisible layer on top of each
worksheet.

Values
Values, also known as numbers, represent a quantity of some type: sales, number of employees,
atomic weights, test scores, and so on. Values that you enter into cells can be used in formulas or
provide the data used to create a chart. Values also can be dates (such as 4/11/00) or times (such as
3:24 a.m.), and you’ll see that you can manipulate these types of values quite efficiently

Text
Most worksheets also include non-numeric text in some of their cells. You can insert text to serve as
labels for values, headings for columns, or to provide instructions about the worksheet. Text that
begins with a number is still considered text. For example, if you enter an address such as 1425 Main
St. into a cell, Excel considers this to be text rather than a value.
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Formulas
Formulas are what make a spreadsheet a spreadsheet - otherwise, you’d just have a strange word
processor that was good at working with tables. Excel lets you enter powerful formulas that use the
values (or even text) in cells to calculate a result. When you enter a formula into a cell, the formula’s
result appears in the cell. If you change any of the values used by a formula, the formula recalculates
and shows the new result.

Entering Values
Entering values into a cell is quite easy. Just move the cell pointer to the appropriate cell (this makes
it the active cell), enter the value, and press Enter. The value is displayed in the cell, and it also
appears in Excels formula bar. You can, of course, include decimal points when entering values and
dollar signs; plus signs, minus signs, and commas also are allowed. If you precede a value with a
minus sign or enclose it in parentheses, Excel considers it to be a negative number.

Note: Sometimes, the value that you enter won’t be displayed exactly as you enter it. More
specifically, if you enter a large number, it may be converted to scientific notation. Notice, however,
that the formula bar displays the value that you entered originally. Excel simply reformatted the
value so that it would fit into the cell. If you make the column wider, the number is displayed as you
entered it.

Entering Text
Entering text into a cell is just as easy as entering a value: activate the cell, type the text, and press
Enter. A cell can contain a maximum of about 32,000 characters. The 32,000 character limit in a cell
is a dramatic increase over the maximum previous versions, 255 characters. To give you an idea of
how much text can fit into a single cell, consider the fact that this entire chapter has approximately
32,000 characters! If you type an exceptionally long text entry into a cell, the characters appear to
wrap around when they reach the right edge of the window, and the formula bar expands so that the
text wraps around.

What happens when you enter text that’s longer than its column’s current width? If the cells to the
immediate right are blank, Excel displays the text in its entirety, spilling the entry into adjacent cells.
If an adjacent cell is not blank, Excel displays as much of the text as possible (the full text is
contained in the cell; it’s just not displayed). If you need to display a long text string in a cell that’s
adjacent to a non-blank cell, you can edit your text to make it shorter, increase the width of the
column, use a smaller font, wrap the text within the cell so that it occupies more than one line, or use
Excels new “shrink to fit” option

Dates and Times
Often, you need to enter dates and times into your worksheet. To Excel, a date or a time is simply
treated as a value - but it’s formatted to appear as a date or a time. If you work with dates and times,
you need to understand Excels date and time system. Excel handles dates using a serial number
system. The earliest date that Excel can understand is January 1, 1900. This date has a serial number
of 1. January 2, 1900, has a serial number of 2, and so on. This system makes it easy to deal with
dates in formulas. For example, you can enter a formula to calculate the number of days between two
dates. Most of the time, you don’t have to be concerned with Excels serial number date system. You
can simply enter a date in a familiar date format, and Excel takes care of the details behind the
scenes.
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Here is a sampling of the date formats that Excel recognizes. After entering a date, you can format it
to appear in a different date format.

Entered into a Cel l Excels Interpretation
6-1-99 June 1, 1999
6-1-1999 June 1, 1999
6/1/99 June 1, 1999
6/1/1999 June 1, 1999
6-1 /99 June 1, 1999
June 1, 1999 June 1, 1999
Jun 1 June 1 of the current year
June 1 June 1 of the current year
6/1 June 1 of the current year
6-1 June 1 of the current year

As you can see, Excel is rather smart when it comes to recognizing dates that you enter into a cell.
It’s not perfect, however. For example, Excel does not recognize any of the following entries as
dates: June 1 1999, Jun-1 1999, and Jun-1/1999. Rather, it interprets these entries as text. If you plan
to use dates in formulas, make sure that the date you enter is actually recognized as a date;
otherwise, your formulas will produce incorrect results.

Tip: After you enter a date, check the formula bar. If the formula bar displays exactly why you
entered, Excel didn’t interpret the date you entered as a date. If the formula bar displays your entry in
a format like mm/dd/yyyy, that means Excel correctly interpreted your entry as a date.

Working with time values
When working with times, you simply extend Excels date serial number system to include decimals.
In other words, Excel works with times by using fractional days. Here are some examples of time
formats that Excel recognizes.

Entered into a Cell           Excels Interpretation

11:30:00 am 11:30 am
1 1:30:00 AM 11:30 am
1 1:30 pm 11:30 pm
1 1:30 11:30 am

The preceding samples don’t have a day associated with them. You also can combine dates and
times, however, as follows:

Entered into a Cell Excels interpretation

6/1/97 11:30 11:30 a.m. on June 1, 1997

Changing or Erasing Values and Text
It should come as no surprise that you can change the contents of a cell after the fact. After you enter
a value or text into a cell, you can modify it in a number of ways:
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Erase the cell’s contents.
Replace the cell’s contents with something else.
Edit the cell’s contents.

Erasing the contents of a cell
To erase the value, text, or formula in a cell, just activate the cell and press Delete. To erase more
than one cell, select all the cells that you want to erase, and then press Delete. Pressing the Delete
key removes the cell’s contents but doesn’t remove any formatting (such as bold, italic, or a different
number format) that you may have applied to the cell.

For more control over what gets deleted, you can use the Edit > Clear command. This menu item
leads to a submenu with four additional choices (fig. ). These choices are described as follows:

All: Clears everything from the cell
Formats: Clears only the formatting and leaves the value, text, or formula
Contents: Clears only the cell’s contents and leaves the formatting
Comments: Clears the comment (if one exists) attached to the cell

Replacing the contents of a cell
To replace the contents of a cell with something else, just activate the cell and type in your new
entry. It replaces the previous contents. Any formatting that you applied to the cell remains.

Editing the contents of a cell
If the cell contains only a few characters, it’s often easier to simply replace it by typing in new data.
But if the cell contains lengthy text or a complex formula and you need to make a slight
modification, you probably want to edit the cell rather than reenter information.

When you want to edit the contents of a cell, you can use one of three ways to get into cell edit
mode:

Double-click on the cell. This lets you edit the cell contents directly in the cell.
Press F2. This lets you edit the cell contents directly in the cell.
Activate the cell that you want to edit, and then click in the formula bar. This lets you edit the cell
contents in the formula bar.

Editing a cell’s contents works pretty much as you might expect. When you begin editing a cell, the
cursor changes to a vertical bar, and you can move the vertical bar by using the direction keys. You
can add new characters at the cursor location. After you’re in edit mode, you can use any of the
following keys to move through the cell contents:

Left/right arrow: The left- and right-arrow keys move the cursor left and right one character,
respectively, without deleting any characters.
Ctrl+left/right arrow: Moves the cursor one group of characters to the left and right, respectively.
A group of characters is defined by a space characters.
Backspace: Erases the character to the immediate left of the cursor.
Delete: Erases the character to the right of the cursor, or all selected characters.
Insert: When you’re editing, pressing the Insert key places Excel in OVR (Overwrite) mode. Rather
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than add characters to the cell, you overwrite, or replace, existing characters with new ones,
depending on the position of the cursor. If the cursor is above a character and you type in OVR
mode, Excel replaces the old character with the character you type.
Home: Moves the cursor to the beginning of the cell entry.
End: Moves the cursor to the end of the cell entry.
Enter: Accepts the edited data.
While editing a cell, you can use the following key combination to select characters in the cell.
Shift+left/right arrow: Selects characters to the left or right of the cursor.
Shift+Home: Selects all characters from the beginning of the cell to the cursor.
Shift+End: Selects all characters from the cursor to the end of the cell.

���������	lso can use the mouse to select characters while you’re editing a cell. Just click on and
drag the mouse pointer over the characters that you want to select.

Formatting Values
Values that you enter into cells are normally unformatted. In other words, they simply consist of a
string of numerals. In many cases, you want to format the numbers so that they are easier to read or
are more consistent in terms of the number of decimal places shown.

Automatic number formatting
Excel is smart enough to perform some formatting for you automatically. For example, if you enter
12.2% into a cell, Excel knows that you want to use a percentage format and applies it for you
automatically. If you use commas to separate thousands (such as 123,456) Excel applies comma
formatting for you. And if you precede your value with a dollar sign, the cell will be formatted for
currency.

Formatting numbers
The Formatting toolbar, which is displayed by default, contains several buttons that let you quickly
apply common number formats. When you click on one of these buttons, the active cell takes on the
specified number format. You also can select a range of cells (or even an entire row or column)
before clicking on these buttons. If more than one cell is selected, the number format is applied to all
the selected cells.

Formatting toolbar buttons perform the following:

Button Name Formatting Applied
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In some cases, the number formats accessible from the Formatting toolbar (or using the shortcut key
combination) are just fine. More often, however, you want more control over how your values
appear. Excel offers a great deal of control over number formats.

There are several ways to bring up the Format Cells dialog box. Start by selecting the cell or cells
that you want to format, and then

Select the Format -> Cells command.
Right-click and choose Format Cells from the shortcut menu.
Press the Ctrl+1 shortcut key.

The Number tab of the Format Cells dialog box displays 12 categories of number formats from
which to choose. When you select a category from the list box, the right side of the panel changes to
display appropriate options

The Number category has three options that you can control: the number of decimal places
displayed, whether to use a comma for the thousand separator, and how you want negative numbers
displayed. Notice that the Negative Numbers list box has four choices (two of which display
negative values in red), and the choices change depending on the number of decimal places and your

Right click brings the menu up.
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choice for a comma. Also, notice that the top of the panel displays a sample of how the active cell
will appear with the selected number format. After you’ve made your choices, click on OK to apply
the number format to all the selected cells.

Here is a list of the number format categories, along with some general comments.

General: The General number format is the default format. It displays numbers as integers,
decimals, or in scientific notation if the value is too wide to fit in the cell.
Number: This format lets you specify the number of decimal places, whether to use a comma to
separate thousands, and how to display negative numbers (with a minus sign, in red, in parentheses,
or in red and in parentheses).
Currency: This format lets you specify the number of decimal places, whether to use a dollar sign,
and how to display negative numbers (with a minus sign, in red, in parentheses, or in red and in
parentheses). This format always uses a comma to separate thousands.
Accounting: This format differs from the Currency format in that the dollar signs always line up
vertically.
Date: This category lets you choose from 11 date formats.
Time: This category lets you choose from six time formats.
Percentage: This category lets you choose the number of decimal places and always displays a
percent sign.
Fraction: This category lets you choose from among nine fraction formats.
Scientific: This format always displays with an E. You can choose the number of decimal places to
display.
Text: Applying the Text number format to a value causes Excel to treat the value as text (even if it
looks like a value). This feature is useful for items such as part numbers.
Special: This category contains four additional number formats (Zip Code, Zip Code +4, Phone
Number, and Social Security Number).
Custom: This category lets you define custom number formats that aren’t included in any of the
other categories. I describe custom number formats in the next section.

Note: If the cell displays a series of pound signs (such as #########), it means that the column is
not wide enough to display the value using the number format that you selected. The solution is
either to make the column wider or to change the number format.

Basic Cell Formatting
The preceding section discussed number formatting. This section discusses some of the basic
stylistic formatting options available to you. These formatting techniques apply to values, text, and
formulas. The options j discuss in this section are available from the Formatting toolbar. Complete
formatting options are available in the Format Cells dialog box, which appears when you choose the
Format->Cells command. It’s important to remember that the formatting you apply works with the
selected cell or cells. Therefore, you need to select the cell (or range of cells) before applying the
formatting.

Alignment
When you enter text in a cell, it’s normally left-justified in the cell. Values, on the other hand, are
displayed right-aligned in the cell. To change the alignment of a cell’s contents, select the cell and
then click on the appropriate button on the Formatting toolbar. The relevant buttons are as follows:
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••••• Align Left: Aligns the text to the left side of the cell. If the text is wider than the cell, it spills
over to the cell to the right. If the cell to the right is not empty, the text is truncated and not
completely visible.

••••• Center: Centers the text in the cell. If the text is wider than the cell, it spills over to cells on
either side if they are empty. If the adjacent cells aren’t empty, the text is truncated and not
completely visible.

••••• Align Right: Aligns the text to the right side of the cell. If the text is wider than the cell, it spills
over to the cell to the left. If the cell to the left is not empty, the text is truncated and not
completely visible.

••••• Merge and Center: Centers the text in the selected cells and also merges the cells into one cell.

Font and text size
To change the font and the size of the contents of a cell or range, select the cells and then use the
Font and Font Size tools on the Formatting toolbar. These tools are drop-down lists. Click on the
arrow on the tool to display a list of fonts or font sizes  Then choose the font or size that you want.

Attributes
The Formatting toolbar also has buttons that let you make the selected cells bold, italic, or
underlined. As you might expect, clicking on the appropriate tool makes the change. These buttons
actually are toggles. So, if the cell is already bold, clicking on the Bold button takes the bold off.

Borders
Another type of formatting is borders - lines drawn around all or part of selected cells or ranges.
When you click on the Borders button on the Formatting toolbar, it expands to display 12 border
choices in a miniature toolbar. You can drag the toolbar’s title bar and move it anywhere you want.
The Borders tool on the Formatting toolbar can be dragged anywhere on-screen.

To add a border to the selected cell or cells, just click on the icon that corresponds to the type of
border you want. The upper-left icon removes all borders from the selected cells. Normally, Excel
displays gridlines in the worksheet to delineate cells. If you add border formatting, you probably
want to turn off the gridline display. To do so, chose the Tools->Options command, click on the
View tab, and uncheck the gridlines check box. This makes it easier to see the effects of borders.
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Colors
The Fill Color tool lets you quickly change the background color of the cell, and the Font Color tool
lets you change the text color. These tools are similar to the Borders tool and also can be moved to a
different location.

Moving the cell pointer
Depending on how Excel is configured, pressing the Enter key after entering data into a cell may
automatically move the cell pointer to another cell. Some users find this annoying; others like it. To
change this setting, choose the Tools->Options command and click on the Edit tab. The check box
that controls this behavior is labeled Move Selection after Enter. You can also specify the direction
in which the cell pointer moves (down, left, up, �
�right). This also is controlled in the Edit panel of
the Options dialog box.

You can use any of the arrow keys instead of Enter. And, not surprisingly, these direction keys send
you in the direction that you indicate. For example, if you’re entering data in a row, press the
right-arrow key rather than Enter. The other arrow keys work as expected, and you can even use
PgUp and PgDn.

Automatic decimal points
If you’re entering lots of numbers with a fixed number of decimal places, you may be interested in
this tip that makes Excel work like some adding machines. Select the Tools->Options command and
click on the Edit tab. Check the check box labeled Fixed Decimal and make sure that it’s set for two
decimal places. When the Fixed Decimal option is set, Excel supplies the decimal points for you
automatically. For example, if you enter 12345 into a cell, Excel interprets it as 123.45 (it adds the
decimal point). To restore things back to normal, just uncheck the Fixed Decimal check box in the
Options dialog box.  Changing this setting doesn’t affect any values that you have already entered.

Text Wrap
If you have lengthy text in a cell, you can force Excel to display it in multiple lines within the cell.
Use Alt+Enter to start a new line in a cell. When you add a line break, Excel automatically changes
the cell’s format to Wrap Text. Another method of text wrap is to choose Format > Cells. From the
Format Cells dialog box (see the next page figure), select Alignment tab and check the Wrap Text
checkbox then click Ok..

Fill color Font color
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Format Cell dialog box.

Working with Cells and Ranges
As you know, a cell is a single addressable element in a worksheet that can hold a value, text, or a
formula. A cell is identified by an address, which is made up of its column letter and row number.
For example, cell D12 is the cell in the fourth column and the twelfth row.

A group of cells is called a range. You designate a range address by specifying its upper-left cell
address and its lower right cell address, separated by a colon.

Here are some examples of range addresses:

A1:B1 Two cells that occupy one row and two columns
C24 A range that consists of a single cell
A1:A100 100 cells in column A
A1:D416 cells (four rows by four columns)
C1:C65536 An entire column of cells; this range also can be expressed as C:C
A6:IV6 An entire row of cells; this range also can be expressed as 6:6
AI:IV65536 All cells in a worksheet

Selecting ranges
To perform an operation a range of cells in a worksheet, you must select the range of cells first. For
example, if you want to make the text bold for a range of cells, you must select the range and then
click on the Bold button on the Formatting toolbar (or, use any of several other methods to make the
text bold).
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When you select a range, the cells appear in reverse video. The exception is the active cell, which
remains its normal color. You can select a range in several ways:

• Click on the mouse and drag to highlight the range. If you drag to the end of the screen, the
worksheet will scroll.

• Press the Shift key while you use the direction keys to select a range.
• Press F8 and then move the cell pointer with the direction keys to highlight the range. Press F8

again to return the direction keys to normal movement.
• Use the Edit->Go To command (or press F5) and enter a range’s address manually into the Go

To dialog box. When you click on OK, Excel selects the cells in the range that you specified.

You can select entire rows and columns much as you select ranges. There are several ways to do
this:

• Click on the row or column border to select a single row or column.
• To select multiple adjacent rows or columns, simply click on a row or column border and drag to

highlight additional rows or columns.
• To select multiple (nonadjacent) rows or columns, press Ctrl while you click on the rows or

columns that you want.
• Press Ctrl+spacebar to select a column. The column of the active cell (or columns of the selected

cells) will be highlighted.
• Press Shift+spacebar to select a row. The row of the active cell (or rows of the selected cells) will

be highlighted.
• Click on the Select All button (or Ctrl+Shift+spacebar) to select all rows. Selecting all rows is

the same as selecting all columns, which is the same as selecting all cells.

Selecting noncontiguous ranges
Most of the time, the ranges that you select will be contiguous - a single rectangle of cells. Excel
also lets you work with noncontiguous ranges. A noncontiguous range consists of two or more
ranges (or single cells), not necessarily next to each other. This is also known as a multiple selection.
If you want to apply the same formatting to cells in different areas of your worksheet, one approach
is to make a multiple selection. When the appropriate cells or ranges are selected, the formatting that
you select is applied to them all. You can select a noncontiguous range in several ways:

• Hold down Ctrl while you click the mouse and drag to highlight the individual cells or ranges.
• From the keyboard, select a range as described previously (using F8 or the Shift key). Then press

Shift+FS to select another range without canceling the previous range selections.
• Use the Edit->Go To command and enter a range’s address manually into the Go To dialog box.

Separate the different ranges with a comma. When you click on OK, Excel selects the cells in the
ranges that you specified.

Annotating a Cell
Excel’s cell comment feature lets you attach a comment to a cell. This feature is useful when you
need to document a particular value. It’s also useful to help you remember what a formula does. In
previous versions of Excel, cell comments were known as cell notes.  Excel 97 not only changed the
name of this feature, but added quite a bit of new functionality.
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To add a comment to a cell, select the cell and choose the Insert->Comment command (or Shift+F2).
Excel inserts a comment that points to the active cell. Initially, the comment consists of your name.
Enter the text for the cell comment, and then click anywhere in the worksheet to hide the comment.
Cells that have a comment attached display a small red triangle in the upper-right corner. When you
move the mouse pointer over a cell that contains a comment, the comment becomes visible.

Note:Use the Tools->Options command (View tab) to control how cell comment indicators are
displayed. You can turn these indicators off if you like.

If you would like all cell comments to be visible (regardless of the location of the
Tip    cell pointer), use the View->Comments command. This command is a toggle; select it again to
hide all cell comments. To edit a comment, activate the cell, right-click, and choose Edit Comment
from the shortcut menu

To delete a cell comment, activate the cell that contains the comment, right-click, and choose Delete
Comment from the shortcut menu.

Deleting Cell Contents
To erase the contents of a cell or range, select the cell or range and press Delete. Or you can use the
Edit->Clear command, which provides additional options.

Tip To erase cells using only the mouse, select the cell or range to be deleted. Then click on the
fill handle - the small square at the lower right of the selection indicator. When you move the mouse
pointer over the fill handle, the pointer changes to a cross. As you drag up and/or to the left, Excel
grays out the selection. Release the mouse button to erase the contents of the grayed selection.

Copying a Range
Copying the contents of a cell is a very common operation. You can do any of the following:

• Copy a cell to another cell.
• Copy a cell to a range of cells. The source cell is copied to every cell in the destination range.
• Copy a range to another range. Both ranges must be the same size.

Note:  Copying a cell normally copies the cell contents, any formatting that was applied to the
original cell, and the cell comment (if it has one). When you copy a cell that tams a formula, the cell
references in the copied formulas are changed automatically to be relative to their new destination.
More on this in the next chapter.

Copying consists of two steps:

1. Select the cell or range to copy (the source range) and copy it to the Windows Clipboard.
2. Move the cell pointer to the range that will hold the copy (the destination range) and paste the
Clipboard contents.
When you paste information, Excel overwrites - without warning - any cells that get in the way. If
you find that some essential cells were overwritten by pasting, execute the Edit->Undo command (or
press Ctrl+Z).
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Because copying is used so often, Excel provides many different methods. I discuss each method in
the following sections.

Pasting all
Selecting the All option in the Paste Special dialog box is equivalent to using the Edit->Paste com-
mand. It copies the cell’s contents, formats, and data validation.

Pasting formulas as values
Normally, when you copy a range that contains formulas, the formulas get copied, and Excel auto-
matically adjusts the cell references. The Values option in the Paste Special dialog box lets you copy
the results of formulas. The destination for the copy can be a new range or the original range. In the
latter case, the original formulas will be replaced by their current values.

Pasting cell formats only
If you’ve applied formatting to a cell or range, you can copy only the formatting and paste it to
another cell or range. Use the Formats option in the Paste Special dialog box. This can save a great
deal of time if you’ve applied lots of formatting to a cell and want to duplicate the formatting else-
where.

Pasting cell comments
If you want to copy only the cell comments from a cell or range, use the Comments option in the
Paste Special dialog box. This option doesn’t copy cell contents or formatting.

Pasting validation criteria
If you’ve created validation criteria for a particular cell (by using the Data -> Validation command),
you can copy the validation criteria to another cell or range. Use the Validation option in the Paste
Special dialog box.

Creating and Using Formulas
Formulas are what make a spreadsheet so useful. Without formulas, a spreadsheet would be nothing
more than a word processor with a very powerful table feature (and not much else). A worksheet
without formulas is essentially dead. Using formulas adds life and lets you calculate results from the
data stored in the worksheet. This chapter introduces formulas and helps you get up to speed with
this important element.

Introducing Formulas
To add a formula to a worksheet, you enter it into a cell. You can delete, move, and copy formulas
just like any other item of data. Formulas use arithmetic operators to work with values, text,
worksheet functions, and other formulas to calculate a value in the cell. Values and text can be
located in other cells, which makes changing data easy and gives worksheets their dynamic nature.
For example, Excel recalculates formulas if the value in a cell used by the formula changes. In
essence, you can see multiple scenarios quickly by changing the data in a worksheet and letting
formulas do the work.

A formula entered into a cell can consist of any of the following elements:
• Operators such as + (for addition) and * (for multiplication)
• Cell references (including named cells and ranges)
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• Values
• Worksheet functions (such as SUM or AVERAGE)

A formula can consist of up to 1,024 characters. After you enter a formula into a cell, the cell dis-
plays the result of the formula. The formula itself appears in the formula bar when the cell is acti-
vated, however.

Here are a few examples of formulas:

=150*.05 Multiplies 150 times .05. This formula uses only
values and isn’t all that useful.

=A1+A2 Adds the values in cells A1 and A2.
=Income-Expenses Subtracts the cell named E x p e n s e s from the cell

named Income.
=SUM(A1:A12) Adds the values in the range Al:A12.
=A1=C12 Compares cell A1 with cell C12. If they are identical,

the formula returns TRUE, otherwise it returns
FALSE.

Note: Notice that formulas always begin with an equal sign. This is how Excel distinguishes formu-
las from text.

Operators used in formulas
Excel lets you use a variety of operators in your formulas. The following table lists the operators that
Excel recognizes. In addition to these, Excel has many built-in functions that let you perform more
operations.

Operator Name
+ Addition
- Subtraction
* Multiplication
/ Division
^ Exponentiation
& Concatenation
= logical comparison (equal to)
> Logical comparison (greater than)
< Logical comparison (less than)
>= Logical comparison (greater than or equal to)
<= Logical comparison (less than or equal to)
<> Logical comparison (not equal to)

You can, of course, use as many operators as you need (formulas can be quite complex). The for-
mula =(B2-B3)*B4 subtracts the value in B3 from the value in B2 and then multiplies the result by
the value in B4. If the worksheet had names defined for these cells, the formula would be a lot more
readable. Here’s the same formula after naming the cells:

=(Income-Expenses)*TaxRate
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Operator precedence
In an earlier example, I used parentheses in the formula to control the order in which the calculations
occur. The formula without parentheses would look like this:

=Income-Expenses*TaxRate

If you enter the formula without the parentheses, you’ll discover that Excel computes the wrong
answer. To understand why this is so, you need to understand a concept called operator precedence.
This is basically the set of rules that Excel uses to perform its calculation. The following table lists
Excel’s operator precedence. This table shows that exponentiation has the highest precedence (that
is, it’s performed first) and logical comparisons have the lowest precedence.

You use parentheses to override Excel’s built-in order of precedence. Returning to the previous
example, the formula that follows doesn’t use parentheses and is therefore evaluated using Excel’s
standard operator precedence. Because multiplication has a higher precedence, the Expense cell is
multiplied by the TaxRate cell. Then this result is subtracted from Income. This isn’t what was
intended.

=Income-Expenses*TaxRate

The correct formula, which follows, uses parentheses to control the order of operations. Expressions
within parentheses are always evaluated first. In this case, Expenses is subtracted from Income and
the result is multiplied by TaxRate.

=(Income-Expenses)*TaxRate

Symbol                 OperatorPrecedence

^ Exponentiation 1
* Multiplication 2
/ Division 2
+ Addition 3
- Subtraction 3
& Concatenation 4
= Equal to 5
< Less than 5
> Greater than 5

You can also nest parentheses in formulas. Nesting means putting parentheses inside of parentheses.
If you do so, Excel evaluates the most deeply nested expressions first and works its way out. The
following formula shows an example of a formula that uses nested parentheses.

=((B2*C2)+(B3*C3)+(B4*C4))*B6

This formula has four sets of parentheses - three sets are nested inside the fourth set. Excel evaluates
each nested set of parentheses and then adds up the three results. This sum is then multiplied by the
value in B6.
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It’s a good idea to make liberal use of parentheses in your formulas. I often use parentheses even
when they aren’t necessary to clarify the order of operations and make the formula easier to read. For
example, if you want to add 1 to the product of two cells, the following formula will do it:

=1+A1*A2

It is much clearer, however, to use the following formula (with superfluous parentheses):

=1+(A1*A2)

Every left parenthesis, of course, must have a matching right parenthesis. If you have many levels of
nested parentheses, it can sometimes be difficult to keep them straight. If the parentheses don’t
match, Excel pops up a message telling you so and won’t let you enter the formula. Fortunately,
Excel lends a hand in helping you match parentheses. When you’re entering or editing a formula that
has parentheses, pay attention to the text. When the cursor moves over a parenthesis, Excel momen-
tarily makes it and its matching parenthesis bold. This lasts for less than a second, so be alert.

In some cases, if your formula contains mismatched parentheses, Excel may pose a correction to
your formula. using the Formula AutoCorrect feature. It’s tempting to simply accept the proposed
correction, but be careful. In many cases the proposed formula, although syntactically correct, isn’t
the formula that you want!

Excel’s built-in functions
Excel provides a bewildering number of built-in worksheet functions that you can use in your formu-
las. These include common functions (such as SUM, AVERAGE, and SQRT) as well as functions
designed for special purposes such as statistics or engineering. Functions can greatly enhance the
power of your formulas. They can simplify your formulas and make them easier to read; in many
cases, functions let you perform calculations that would not be possible otherwise. If you can’t find a
worksheet function that you need, Excel even lets you create your own custom functions.

Ecel's built-in functions options.
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Functions are built-in formulas for simple or complex calculation. Formulas are treated as values. To
activate a built-in formula, you must first place the cursor in an empty cell where you want to see the
result, then type = (equal sign). This symbol puts Works in a value mode.

Functions consist of the = (equal sign), followed by the name of the function which is abbreviated.
The argument should follow, enclosed in parentheses. Suppose you want to add the values or num-
bers in cells A2, A3, A4, A5, A6, and A7.  The formula for this calculation is =SUM(A2:A7). SUM
is an arithmetic function and the information in the parentheses is the argument. A2 is argument 1,
and A7 is argument 2, all together in a range.  As a result, functions follow this format:

=FUNCTION(argument1:argument2)

Notice that there is no space after any entry.

Excel has nine types of built-in functions: Financial functions, Data & Time functions, Math & Trig
functions, Statistical functions, Look & Reference functions, Database functions, Text functions,
Logical functions, and Information functions. In addition, it has User defined functions in which the
users create their own functions. Some of the major function by subject category are:

Mathematical Functions

Abs(number)
Absolute value of number

Rand( )
Random number between O and I

Round(number,number-of-digits)
Number rounded to number-of-digits

Statistical Functions

Average(values-], values-2, . . . )
Average of values in values

Count(values - I, values-2, . . . )
Count of values in values

Max(values- I, values -2, . . . )
Maximum value in values

Min(values-l ,values-2, . . .)
Minimum value in values

StDev(values-l ,values-2, . . .)
Standard deviation of values
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Sum(values-l, values-2, . . .)
Sum of values

Var(values-l ,values-2, . . .)
Variance of values

Trigonometric Functions

Cos(number)
Cosine of number

Sin(number)
Sine of number

Tan(number)
Tangent of number

Logical Functions

And(values-l, values-2, . . . )
I (TRUE) if all values are non-zero (TRUE); otherwise, O (FALSE)

Choose(index, value-l, value-2, . . . )
Uses index to select a value from the values

If (number, value-if-true, value-if-false)
Value-if-true if number is non-zero (TRUE); value-if-false if number

Or(values-l, values-2, . . . )

Financial Functions

FV(rate, nper, pmt, pv, type)
Future value of investment

NPV(rate, values-I,values-2 )
 Net present value of values

Pmt(rate, nper, pv,f v, type)
Periodic payment of investment

PV(rate, nper,pmt,fv,type)
Present value of investment

Date and TimeFunctions

Date(year, month, day)
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Returns serial number of the specified date

Day(serial number)
Converts serial number to a day of the month

Hour(serial number)
Converts serial number to an hour of the day

Minute(serial number)
Converts serial number to a minute

Month(serial number)
Converts serial number to a month of the year

Now( )
Returns serial number of current date and time

Second(serial number)
Converts serial number to a second

Time(hour, minute,second)
Returns serial number of the specified time

Weekday(serial number)
Converts serial number to a day of the week

Year(serial number)
Converts serial number to a year

Special-purpose Functlons

Lookup(lookup-value, compare-range, result-range)
Value in a table selected by lookup-value

Match(lookup-value, compare-range, type)
Number of a value selected by lookup-value

NA( )
Returns the value N/A

Examples:
=ABS(value)  Presents the absolute value of the argument. This function argument must be

numeric.  The function displays the positive value of the argument.  Example: =ABC(5) = 5, =ABC(0)
= 0, =ABC(-5) = 5.

=AVG(argument1.argument2)  Calculates the mean of all the values included in the argument.
=COUNT(argument1:argument2)  This function calculates the number of non-blank cells given

in the argument or range.
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=INT(value)  Presents the integer portion of the argument.
=MAX(argument1:argument2)  Displays the largest value in the range.
=MIN(argument1:argument2)  Presents the smallest value of the range.
=SQRT(value)  The function calculates the square root of the given value.
=SUM(argument1:argument2)  Calculates the sum of the all values in the range.

Logical functions evaluate values based on the results of the conditional statement.  The result of
the evaluation or comparison is either TRUE or FALSE.

If the condition is true, Works operates the first set of values; if the condition is false, the second
set of values will be evaluated.  For example, you would like to design an automated grade book for your
class.  Assume that students, total scores is in the cell G6, and the total possible points is 100.  You would
like to assign A or 4 for the scores between 90 - 100 and B or 3 for the scores less than 90.  You may instruct
the program if the total score is >=90 (greater than or equal to), print 4, if not, then print 3.   In this example
you would like to put the result in cell H6.  Place the cursor in cell H6, type the following formula for
this operation, and then press RETURN:

=IF(G1>=90,4,3)

The structure of the logical statement is:

=IF(condition, argument if true, argument if false)

Entering Formulas
As I mentioned earlier, a formula must begin with an equal sign to let Excel know that the cell
contains a formula rather than text. There are basically two ways to enter a formula into a cell: enter
it manually or enter it by pointing to cell references.

Entering formulas manually
Entering a formula manually involves, well, entering a formula manually. You simply type an equal
sign (=) followed by the formula. As you type, the characters appear in the cell as well as in the
formula bar. You can, of course, use all the normal editing keys when entering a formula.

Entering formulas by pointing
The other method of entering a formula still involves some manual typing, but you can simply point
to the cell references instead of entering them manually. For example, to enter the formula =Al+A2
into cell A3, follow these steps:

1. Move the cell pointer to cell A3.
2. Type an equal sign (=) to begin the formula. Notice that Excel displays Enter in the status bar.
3. Press the up arrow twice. As you press this key, notice that Excel displays a faint moving border

around the cell and that the cell reference appears in cell A3 and in the formula bar. Also notice
that Excel displays Point in the status bar.

4. Type a plus sign (+). The faint border disappears and Enter reappears in the status bar.
5. Press the up arrow one more time. A2 is added to the formula.
6. Press Enter to end the formula.
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Pointing to cell addresses rather than entering them manually is usually more accurate and less
tedious.

Excel includes the Formula Palette feature that you can use when entering or editing formulas. To
access the Formula Palette, click on the Edit Formula button in the edit line (it has an image of an
equal sign). The Formula Palette lets you enter formulas manually or use the pointing techniques
described previously. The advantage is that the Formula Palette displays the result of the formula as
it’s being entered. Fig. shows the Formula Palette at work. The Formula Palette normally appears
directly below the edit line, but you can drag it to any convenient location.

The Formula Palette displays the result of the formula as it’s being entered.


